It is currently Tue Dec 11, 2018 6:12 pm

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Mon Oct 03, 2011 2:38 am 
Offline
Moderately Obsessed
Moderately Obsessed
User avatar

Joined: Tue Aug 03, 2010 5:28 am
Posts: 1225
Location: Belgium.
Given: 4308 thanks
Received: 2013 thanks
Bike(s): Steel.
Favorite Trails: Porcupine Rim , Sedona .
Awesome weekend ,first ride on saturday in our Flemish Ardennes (where the tour of Flanders is riddden each year) and on sunday a marathon in the Netherlands.

Great weather , a bit on the hot side and for the first time in ten years i know what a cramp feels like :|

Only took some pics on saturday but when i got home i notice alot of pics having a blur/fuzzy look. Going through my camera settings , nothing wrong. Then i saw that my lens had some "damp" on it. Only a few pics were ok. No pics on sunday , i don't stop for pictures on a marathon.
http://connect.garmin.com/activity/118269758
http://connect.garmin.com/activity/118551441

Image
Image
Image
Image
Image
Image
Image


Top
 Profile  
 
The following 5 users would like to thank Christ D. for his or her post:
Big Clyde, Canaan, Red Hot Sloth, Refriger-Raider, Robo
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group